Free 1z0-066 sample questions
Real questions from the Oracle Database 12c: Data Guard Administration practice bank, with the correct answer and an explanation for each one. No junk, no filler.
Showing 6 of 12 free sample questions.
Which four database parameters might be affected by or influence the creation of standby databases? (Choose four.)
Correct answers: DB NAME; DB FILE NAME CONVERT; DB_UNIQUE_NAME; FAL SERVER
A, D, E, F -- Explanation:A: DB_NAMEOn a primary database, specify the name used when the database was created. On a physical standby database, use the DB_NAME of the primary database. C: Ensure the COMPATIBLE initialization parameter is setto the same value on both the primary and standby databases. if the values differ, redo transport services may be unable to transmit redo data from the primary database to the standby databases. D: DB_FILE_NAME_CONVERTSpecify the path name and filename location of the primary database data files followed by the standby location. This parameter converts the path names of the primary database data files to the standby data file path names. E: DB_UNIQUE_NAMESpecify a unique name for each database. This name stays with the database and does not change, even if the primary and standby databases reverse roles. F: FAL_SERVERSpecify the Oracle Net service name of the FAL server (typically this is the database running in the primary role). -- Reference: https://docs.oracle.eom/database/121/SBYDB/create ps.htm#SBYDB4720
A, D, E, F -- Explanation:A: DB_NAMEOn a primary database, specify the name used when the database was created. On a physical standby database, use the DB_NAME of the primary database. C: Ensure the COMPATIBLE initialization parameter is setto the same value on both the primary and standby databases. if the values differ, redo transport services may be unable to transmit redo data from the primary database to the standby databases. D: DB_FILE_NAME_CONVERTSpecify the path name and filename location of the primary database data files followed by the standby location. This parameter converts the path names of the primary database data files to the standby data file path names. E: DB_UNIQUE_NAMESpecify a unique name for each database. This name stays with the database and does not change, even if the primary and standby databases reverse roles. F: FAL_SERVERSpecify the Oracle Net service name of the FAL server (typically this is the database running in the primary role). -- Reference: https://docs.oracle.eom/database/121/SBYDB/create ps.htm#SBYDB4720
A, D, E, F -- Explanation:A: DB_NAMEOn a primary database, specify the name used when the database was created. On a physical standby database, use the DB_NAME of the primary database. C: Ensure the COMPATIBLE initialization parameter is setto the same value on both the primary and standby databases. if the values differ, redo transport services may be unable to transmit redo data from the primary database to the standby databases. D: DB_FILE_NAME_CONVERTSpecify the path name and filename location of the primary database data files followed by the standby location. This parameter converts the path names of the primary database data files to the standby data file path names. E: DB_UNIQUE_NAMESpecify a unique name for each database. This name stays with the database and does not change, even if the primary and standby databases reverse roles. F: FAL_SERVERSpecify the Oracle Net service name of the FAL server (typically this is the database running in the primary role). -- Reference: https://docs.oracle.eom/database/121/SBYDB/create ps.htm#SBYDB4720
A, D, E, F -- Explanation:A: DB_NAMEOn a primary database, specify the name used when the database was created. On a physical standby database, use the DB_NAME of the primary database. C: Ensure the COMPATIBLE initialization parameter is setto the same value on both the primary and standby databases. if the values differ, redo transport services may be unable to transmit redo data from the primary database to the standby databases. D: DB_FILE_NAME_CONVERTSpecify the path name and filename location of the primary database data files followed by the standby location. This parameter converts the path names of the primary database data files to the standby data file path names. E: DB_UNIQUE_NAMESpecify a unique name for each database. This name stays with the database and does not change, even if the primary and standby databases reverse roles. F: FAL_SERVERSpecify the Oracle Net service name of the FAL server (typically this is the database running in the primary role). -- Reference: https://docs.oracle.eom/database/121/SBYDB/create ps.htm#SBYDB4720
Which three are prerequisites for enabling Fast-Start Failover? (Choose three.)
Correct answers: Flashback Database must be enabled on both the primary database and the Fast-Start Failover target standby database.; The configuration must be operating in either Maximum Performance or Maximum Availability mode.; The Data Guard environment must be managed by the Data Guard Broker.
B, D, F -- Explanation: B: You enable the Flashback Mode both on the primary database and on the standby database. D: In Maximum Availability mode, Fast-Start Failover (FSFO) guarantees that no transaction that has received a commit acknowledgment will be lost during a failover. Oracle Database 11g FSFO adds support for Maximum Performance mode (async redo transfer), providing the flexibility to trade durability for performance. F: The Dataguard Broker Observer (Observer) is used when fast start failover is required. Fast start failover is simply an automatic failover to the standby database Incorrect answers: C: You enable the Flashback Mode both on the primary database and on the standby database. References: http://dbasoumya.blogspot.se/2015/07/fast-start-failoverfsfo-in-oracle-11g.html http://www.oracle.com/technetwork/articles/smiley-fsfo-084973.html
B, D, F -- Explanation: B: You enable the Flashback Mode both on the primary database and on the standby database. D: In Maximum Availability mode, Fast-Start Failover (FSFO) guarantees that no transaction that has received a commit acknowledgment will be lost during a failover. Oracle Database 11g FSFO adds support for Maximum Performance mode (async redo transfer), providing the flexibility to trade durability for performance. F: The Dataguard Broker Observer (Observer) is used when fast start failover is required. Fast start failover is simply an automatic failover to the standby database Incorrect answers: C: You enable the Flashback Mode both on the primary database and on the standby database. References: http://dbasoumya.blogspot.se/2015/07/fast-start-failoverfsfo-in-oracle-11g.html http://www.oracle.com/technetwork/articles/smiley-fsfo-084973.html
B, D, F -- Explanation: B: You enable the Flashback Mode both on the primary database and on the standby database. D: In Maximum Availability mode, Fast-Start Failover (FSFO) guarantees that no transaction that has received a commit acknowledgment will be lost during a failover. Oracle Database 11g FSFO adds support for Maximum Performance mode (async redo transfer), providing the flexibility to trade durability for performance. F: The Dataguard Broker Observer (Observer) is used when fast start failover is required. Fast start failover is simply an automatic failover to the standby database Incorrect answers: C: You enable the Flashback Mode both on the primary database and on the standby database. References: http://dbasoumya.blogspot.se/2015/07/fast-start-failoverfsfo-in-oracle-11g.html http://www.oracle.com/technetwork/articles/smiley-fsfo-084973.html
Examine the Data Guard configuration: DGMGRL) show configuration; Configuration-Animals Protection Mode: MaxAvailability Databases: dogs - Primary database dogsfs1 - Far Syncs heep - Physical standby database Fast-Start Failover: DISABLED Configuration Status: SUCCESS An attempt to enable fast-start failover raises an error: DGMGRL> enable fast_start failover; Error: ORA-16693: requirements not metfor enabling fast-startfailover Failed. Identify two possible reasons for this error. (Choose two.)
Correct answers: The FastStartFailoverTarget property is not set on Sheep.; The LogXptMode property is set to ASYNC on Dogs.
A, D -- Explanation: D: Ensure that the LogXptMode property for both the primary database and the Fast-Start Failover target standby database are SYNC.A: If more than one physical or logical standby database exists, in this case it is the sheep database, you must specify the FastStartFailoverTarget value explicitly, prior to enabling fast-start failover. The indicated target is verified when fast-start failover is enabled. Note: DGMGRL) enablefast_startfailover;Error: ORA-16651: requirements not metfor enabling fast-startfailoverFailed. SOLUTION1) Check whether the flashback database is enabled on primary and standby database Select flashback_on from gv$database;2) Checkwhether you have setthe FastStartFailoverTarget parameter. References: docs.oracle.com/cd/E11882_01/server. 112/e40771 /dbpropref.htm#DGBKR862')https://docs.oracle.com/cd/E11882_01/server. 112/e40771 /dbpropref.htm#DGBKR862 psoug.org/oraerror/OR')http://psoug.org/oraerror/ORA-16651.htm
A, D -- Explanation: D: Ensure that the LogXptMode property for both the primary database and the Fast-Start Failover target standby database are SYNC.A: If more than one physical or logical standby database exists, in this case it is the sheep database, you must specify the FastStartFailoverTarget value explicitly, prior to enabling fast-start failover. The indicated target is verified when fast-start failover is enabled. Note: DGMGRL) enablefast_startfailover;Error: ORA-16651: requirements not metfor enabling fast-startfailoverFailed. SOLUTION1) Check whether the flashback database is enabled on primary and standby database Select flashback_on from gv$database;2) Checkwhether you have setthe FastStartFailoverTarget parameter. References: docs.oracle.com/cd/E11882_01/server. 112/e40771 /dbpropref.htm#DGBKR862')https://docs.oracle.com/cd/E11882_01/server. 112/e40771 /dbpropref.htm#DGBKR862 psoug.org/oraerror/OR')http://psoug.org/oraerror/ORA-16651.htm
You are licensed to use Oracle Active Data Guard. Which two statements are true after enabling block change tracking on a physical standby database? (Choose two.)
Correct answers: It allows fast incremental backups to be offloaded to the physical standby database.; It starts the CTWR process on the physical standby database instance.
A, B -- Explanation: A: Many of the customers now are opting to perform RMAN backups on standby database to offload the resources of production database. B: To enable Active Data Guard on a standby database, set the ENABLE_CPTIDN_ACTIVE_DATA_GUARD initialization parameter to TRUE. Note: Fast Incremental backups is possible with Block change tracking, which is initially introduced from version 10.2 onwards, by this tool it's very useful to reduce the RMAN incremental backup duration but it is limited only for Primary database. From 11g Grade with Active Data Guard feature we can use Block change tracking even on Physical standby database. References: www.morganslibrary.org/reference/block_ch')http://www.morganslibrary.org/reference/block_change_tracking.html
A, B -- Explanation: A: Many of the customers now are opting to perform RMAN backups on standby database to offload the resources of production database. B: To enable Active Data Guard on a standby database, set the ENABLE_CPTIDN_ACTIVE_DATA_GUARD initialization parameter to TRUE. Note: Fast Incremental backups is possible with Block change tracking, which is initially introduced from version 10.2 onwards, by this tool it's very useful to reduce the RMAN incremental backup duration but it is limited only for Primary database. From 11g Grade with Active Data Guard feature we can use Block change tracking even on Physical standby database. References: www.morganslibrary.org/reference/block_ch')http://www.morganslibrary.org/reference/block_change_tracking.html
A Data Guard environment has this configuration and these attributes: 1. A primary database 2. A Physical Standby Database named sbdb 3. The configuration is in maximum availability protection mode. Then sbdb is converted to a snapshot standby database. When two statements are true? (Choose two.)
Correct answers: The recovery time objective increases.; Sbdb can still receive redo
D, E -- Explanation: E: A snapshot standby database receives and archives, but does not apply, redo data from a primary database. D: Snapshot standby databases are best used in scenarios where the benefit of having a temporary, updatable snapshot of the primary databasejustifies additional administrative complexity and increased time to recover from primary database failures. Note: Redo data received from the primary database is applied when a snapshot standby database is converted back into a physical standby database, after discarding all local updates to the snapshot standby database. The data in the primary database is fully protected however, because a snapshot standby can be converted back into a physical standby database at any time, and the redo data received from the primary will then be applied. Incorrect answers:A: snapshot standby database receives and archives, but does not apply, redo data from a primary database. References: https://docs.oracle.com/cd/B28359 Q1/server.111/b28294/manage ps.htm
D, E -- Explanation: E: A snapshot standby database receives and archives, but does not apply, redo data from a primary database. D: Snapshot standby databases are best used in scenarios where the benefit of having a temporary, updatable snapshot of the primary databasejustifies additional administrative complexity and increased time to recover from primary database failures. Note: Redo data received from the primary database is applied when a snapshot standby database is converted back into a physical standby database, after discarding all local updates to the snapshot standby database. The data in the primary database is fully protected however, because a snapshot standby can be converted back into a physical standby database at any time, and the redo data received from the primary will then be applied. Incorrect answers:A: snapshot standby database receives and archives, but does not apply, redo data from a primary database. References: https://docs.oracle.com/cd/B28359 Q1/server.111/b28294/manage ps.htm
6 more free samples are waiting
Create a free account to unlock the whole 1z0-066 sample bank, or get full access to all 112 practice questions in the simulator.